Crash bug with LGBTQ Pride Flags for Custom Furniture (CF) on Nexus Mods

beetlewizard

Greenhorn
Experiencing an issue with this mod. The pride flags were available at Pierre's pop-up shop during the Lua'u but without a price, I bought the 1978 pride flag and it cost me nothing and was put in the right most slot in the hotbar. Only until the next day did I realize I could not interact with it at all, and when I hold it in my hands, it crashes my entire game. I've uninstalled the mod, and tho it got rid of the item, going to that slot still crashes my game, reinstalled and it still persists. Took off a transmasc flag I had on the wall which I bought a while ago with money, held it in my hotbar and it also crashed my game. I was testing out the Save Anywhere mod and stupidly I saved twice the next day, after I had bought the item. This bug makes this save pretty much unplayable and I really don't want to lose it, is there anything I can do about this? I have multiple other mods as well.
 
Howdy, we can fix the save.

You can see my previous comment on this thread for some extra info: https://forums.stardewvalley.net/th...ng-spacecore-and-json-assets.18728/post-95881

But, basically; you'll need to temporarily remove all the CF mods you have, so it doesn't happen again. I saw you mentioned you uninstalled this one, but if you have any other CF mods; it could potentially crash again later.
And, then we need to check/edit the "spacecore-serialization.json" file from your save. As it has all the CF items stored there.
Removing the CF items from the saved data will stop the crashes.

Find your save, zip up the folder for that save. And, then post it here; please.
 
here's my save, tysm for helping! apologies for the very late reply.
No worries, and thanks for the save!

I took a look, and it looks like your inventory, and chests are clear of the items. So, your save is okay.

The only place the CF items are in, is the spacecore-serialization.json file.
As there's no other custom items except CF items; you can delete that file.

So, just delete that file from your save folder, and ensure all CF mods are uninstalled, and you should be good to go.
 

beetlewizard

Greenhorn
So I deleted that file, went on and the crash still happened when going over that hotbar slot. But it's probably cause I have other CF mods in my mod folder, but I don't know how to identify them if there is. Sorry if I missed something you said, I'm not very computer savvy and I'm bad at understanding things w/o super clear instructions.
 
So I deleted that file, went on and the crash still happened when going over that hotbar slot. But it's probably cause I have other CF mods in my mod folder, but I don't know how to identify them if there is. Sorry if I missed something you said, I'm not very computer savvy and I'm bad at understanding things w/o super clear instructions.
Hrm, okay. No worries.

Can you upload your SMAPI log here: https://smapi.io/log/
It has some instructions for doing so, and then share the link it creates.

It'll show us all the mods you currently have installed, and potentially the most recent error.
 
hopefully i did it right. tysm for helping me again, sorry i'm a little slow.

Yea, that's right; thanks!
No worries; you're good. Actually after checking the log you posted, and rechecking the save you sent me.

I realized I messed up. It looks like the inventory data is saved in the other json file. The spacecore-serialization-farmer.json file.
Delete that one as well.

It's usually all in the other one. But, I guess the first one is a more general furnitiure on the farm map, and other locations. While, this "farmer' one is the separate data for the player inventory.
I was testing without CF installed; so it didn't error for me.
Sorry bout that!
 
deleted that file, crash still happens :sweat: just hovering over the inventory slot causes a bunch of red text in the SMAPI thing. i also updated my mods, including Platonic Partners and Friendships 2.2.0 to 2.2.1, but it says it still needs to update, as if it's there twice? idk if that's related or not

Ah sorry, for the late reply.
That's odd, that should've fixed everything. But, we can try/verify a few things.

First, let's remove CustomFurniture, and PyTK as well. We should really only need to remove the mods for it, but something is acting strange.

Second, you're missing ErrorHandler which helps with some bugs; probably not with this. Normally, you can re-grab it by reinstalling SMAPI or extracting the installer files.
But, I'm adding it directly here. Just unpack it, and place it in your Mods folder.

Lastly, just to verify that the 2 spacecore files in the DIno save are gone. Here's an example attached.
 

Attachments

beetlewizard

Greenhorn
oh my god it's finally fixed, holy crap. thank you so much for the help, you have been an actual saint. i've removed those spacecore files multiple times, but they keep showing up for some reason? but even if i have to delete them everytime, at least i can play and didn't lose this save haha. really tho, thank you so much for taking the time to help me, it means a lot. hopefully you won't see me send another message from me in the near future. thank you! :heart: :heart: :heart: (i hope i'm not saying this too soon)
 
oh my god it's finally fixed, holy crap. thank you so much for the help, you have been an actual saint. i've removed those spacecore files multiple times, but they keep showing up for some reason? but even if i have to delete them everytime, at least i can play and didn't lose this save haha. really tho, thank you so much for taking the time to help me, it means a lot. hopefully you won't see me send another message from me in the near future. thank you! :heart: :heart: :heart: (i hope i'm not saying this too soon)
Awesome! Glad, that finally fixed it up
The files should/will reappear; since its created by SpaceCore. But, as long as they don't have any CF data in them it's okay.

I'm wondering if Steam or something is saving/redownloading the original SpaceCore files or something.

But, yea; glad to help anytime!
 
Top