PC Stale game version (1.5.4) provided through GOG Galaxy on macOS.

ascii7

Tiller
I have both the Steam and GOG versions of SDV on my Mac. (If I'm not playing online, I like to use the GOG version to avoid having to launch both Steam and the game.)

The Steam version updated to 1.5.5, but the GOG version only updated to a "newer" version of 1.5.4. Oddly, the GOG release notes say 1.5.5, but the in-game version displays 1.5.4. I've run "check for updates" several times in Galaxy with no luck getting a real 1.5.5. Further proof is that when I open my "updated" GOG version, it shows a "Version mismatch 1.5.5" for the save file I've been playing on Steam.

Since the GOG release notes describe 1.5.5, my suspicion is that there has been some sort of mistake.

Have Windows GOG users found this also?
 

imnvs

Local Legend
When logged in to your GOG game, can you <ctrl>+<shift> to buy in units of 25? If so, the error is it displaying 1.5.4 after updating.
 

ascii7

Tiller
When logged in to your GOG game, can you <ctrl>+<shift> to buy in units of 25? If so, the error is it displaying 1.5.4 after updating.
I considered the "Version mismatch (1.5.5)" message along with the inability to load my save file as conclusive evidence that the downloaded game version was still 1.5.4.

That said, sometime since this morning they put up a new 1.5.5 version of the game. The bad news was that the new 1.5.5 game install would not launch at all.

I tried deleting and reinstalling. Still would not launch.

I restarted my Mac. Still wouldn't launch.

I downloaded the stand-alone .PKG installer. That would launch 1.5.5 from the finder, but Galaxy would not recognize it as being installed at all.

I reinstalled through Galaxy over top the stand-alone installed game. Everything seems to work now. I can launch the GOG install from both the Finder and Galaxy. Whew!
 
I considered the "Version mismatch (1.5.5)" message along with the inability to load my save file as conclusive evidence that the downloaded game version was still 1.5.4.

That said, sometime since this morning they put up a new 1.5.5 version of the game. The bad news was that the new 1.5.5 game install would not launch at all.

I tried deleting and reinstalling. Still would not launch.

I restarted my Mac. Still wouldn't launch.

I downloaded the stand-alone .PKG installer. That would launch 1.5.5 from the finder, but Galaxy would not recognize it as being installed at all.

I reinstalled through Galaxy over top the stand-alone installed game. Everything seems to work now. I can launch the GOG install from both the Finder and Galaxy. Whew!
I appear to be having the same issue. But when tried to install the stand-alone .PKG installer from GOG, I couldn't even do that. The version available for download is 1.5.5.1835528477. When I try to launch the installer, macOS warns me that it can't be opened because it can't be checked for malicious software; it does't even give me the option to "install anyway" (screenshot attached). I have macOS set to allow apps downloaded from the "App Store and identified developers", and I have been able to install other software from outside the App Store, so it looks as though one issue may be that the installer hasn't been signed properly or some certificate has expired.

I also tried turning off automatic updates in GOG Galaxy and downloading other versions from there. Neither version 1.5.5.1848868231 (the most recent available as I write) nor 1.5.5.1835528477 work. When I click Play in Galaxy using either version, the Play button shows the "Synching" message, then reverts to "Play" (grayed out), then back to "Synching", then back again to "Play" (not grayed out). Reverting back to version 1.5.4.1396293314 allowed the game to run.
 

Attachments

ascii7

Tiller
I appear to be having the same issue. But when tried to install the stand-alone .PKG installer from GOG, I couldn't even do that. The version available for download is 1.5.5.1835528477. When I try to launch the installer, macOS warns me that it can't be opened because it can't be checked for malicious software; it does't even give me the option to "install anyway" (screenshot attached). I have macOS set to allow apps downloaded from the "App Store and identified developers", and I have been able to install other software from outside the App Store, so it looks as though one issue may be that the installer hasn't been signed properly or some certificate has expired.

I also tried turning off automatic updates in GOG Galaxy and downloading other versions from there. Neither version 1.5.5.1848868231 (the most recent available as I write) nor 1.5.5.1835528477 work. When I click Play in Galaxy using either version, the Play button shows the "Synching" message, then reverts to "Play" (grayed out), then back to "Synching", then back again to "Play" (not grayed out). Reverting back to version 1.5.4.1396293314 allowed the game to run.
Sorry my trick didn't work for you. Your symptoms of Synching, "Play" grayed out, Synching sounds the same as what I experienced before I finally got it working. Hard to say what might be going on now. The .PKG installer that I saw in Galaxy just a moment ago (1.5.5.1835528477) is slightly older than the hot fix that came through Galaxy autoupdate last night (1.5.5.1848868231). Maybe sometime soon they will post the newer version as a .PKG. If so, it may be worth a try to see if it does any better.
 
Top