Mobile [BUG] Artifacts found not showing in collection

Technetium

Newcomer
I've been told by someone that this is a "known bug" but I didn't see a thread here for it.

The last 4 artifacts I've found are still greyed out in the artifacts collection page. They are sitting in the museum right now. Some of them I have found multiple copies of and sold extras. The ones that have this problem for me are: Dinosaur Egg, Rare Disc, Ancient Sword, and Ancient Seed. I've just found my second Ancient Seed and it still won't show in the collection. I've tried to see if I can re-trigger it by putting it in a chest and picking it back up, starting the day with it in my inventory... none of these things work.

Does anyone know a workaround, or if this is something they will likely fix soon? I am playing for 100% completion, so any greyed-out artifacts need to be resolved.
 

CypressEQ

Newcomer
I'm playing on the touchscreen of my Tesla. I also have this same issue. The artifacts seem to clear out almost every day or so. I've found dozens of artifacts sometimes 1 or 2 will show as part of my collection but within a day or so the whole collection is reset.
 

ric

Mobile Developer
I've been told by someone that this is a "known bug" but I didn't see a thread here for it.

The last 4 artifacts I've found are still greyed out in the artifacts collection page. They are sitting in the museum right now. Some of them I have found multiple copies of and sold extras. The ones that have this problem for me are: Dinosaur Egg, Rare Disc, Ancient Sword, and Ancient Seed. I've just found my second Ancient Seed and it still won't show in the collection. I've tried to see if I can re-trigger it by putting it in a chest and picking it back up, starting the day with it in my inventory... none of these things work.

Does anyone know a workaround, or if this is something they will likely fix soon? I am playing for 100% completion, so any greyed-out artifacts need to be resolved.
Which build are you playing? This issue was recently fixed. Make sure you're running the latest version. If the issue still occurs please report back to us and we'll look into it.
 

stardewer

Newcomer
I just bought the game recently (probably 2 weeks ago) on Google Play which i believe should be the latest version? and i am having the same issues, some artifacts donated just won't show in the collection...
 

Starlight

Newcomer
Same issue here I bought the game in appstore ancient seed and sword not showing in artifacts collection but already donated in museum the game is in latest versionA5AF4F29-F490-4B9A-BCD9-A122662CF68D.png
A5AF4F29-F490-4B9A-BCD9-A122662CF68D.png
A5AF4F29-F490-4B9A-BCD9-A122662CF68D.pngC593298C-8E51-40DD-BC6F-4960CA46CD22.png
 

miss-mushroom

Newcomer
Same here - found Elven Jewelry, Ancient Sword, Bone Flute, possibly one or two others, all donated to the museum but they do not appear in the collections tab. I have actually found two Ancient Swords and still nothing. I think all the 'missing' ones I found in fishing chests.

Playing on Android with latest version of the game.

Hopefully this is fixed soon as I am a total completionist!!
 

StarLord

Newcomer
Same problem here on iPhone. Please fix, my life will feel incomplete, if I can’t complete the museum collection. True story. 😢
 

dewymango

Newcomer
I’m also having this problem. Latest SDV version on latest version of IOS. Sorry its not the most organized, but from what I can tell it’s the rare disk, bone flute, ancient sword, nautilus fossil, and skeletal tail that are missing from the collection but are in the museum. I think I got these from fishing chests. Also, I’ve gotten some of them multiple times now like the rare disk and the flute, and that didn’t make a difference.
B8D94441-FD31-42F4-A50B-E905C941B802.png
AE69A86E-D5A6-4659-BFEE-39646F87F821.png
40ECCC1A-9CB9-4D26-A783-0014899E406A.png
618A2F90-319F-4B97-BBD2-12602D355BF1.png
 

sphinx124

Newcomer
UPDATE: I just completed the museum collection and the achievement came up. The artifacts below are still greyed out in my menu though.
However, I found another Nautilus fossil and now it is present.

I'm playing on the mobile game with Android. The latest version 1.4.5.145
I have the same issue, I only noticed it recently so I'm not sure where I got the items from and I believe it was across multiple days.
My missing artifacts are:
- Rare disc
- Skeletal tail
- Nautilus fossil
- Amphibian fossil

The rest of my collection is complete and visible, except the prehistoric skull which I haven't found yet. I can't donate additional copies to the museum to solve the problem either.
 
Last edited:

weru

Greenhorn
Same problem, Android, both game and system are latest versions, found 3 skeletal tails, donated to museum, shipped and sitting in my inventory and it's not showing in the collection. :cry:
 

Zchka

Greenhorn
Same thing for me. iOS. Only with the nautilus fossil which I’ve found at least five times now and is in the museum. I also did everything I could think of.
 

SluppyB

Greenhorn
This has just happened to me too. Strangely enough, for me it's also the nautilus fossil. Something wrong with this particular item?
 

beccargh

Newcomer
Hi - I have two saves files affected by this. I am on Android with an updated game.

One file I am working on and as you can see the Ancient Sword and Ancient Seed are in the collection but greyed out.

Second file: Ancient Nautilus was found but is greyed out. However, the museum collection is stated as completed.

I decided to look into this further once I realized that because the game doesn't know I found the ancient seed, it's making it harder to find another one (which I can usually find in the hidden sewer room where the Slimejack are). This affects my ability to craft all items.

It's too bad this error exists, but in a mostly perfect game I still feel lucky!
 

Attachments

Rabz10

Newcomer
Which build are you playing? This issue was recently fixed. Make sure you're running the latest version. If the issue still occurs please report back to us and we'll look into it.
Which build are you playing? This issue was recently fixed. Make sure you're running the latest version. If the issue still occurs please report back to us and we'll look into it.
I have recently bought and downloaded Stardew Vally mobile on the andriod. As of OCT 02 20202 i am still experiencing the same error as everyone else even with latest update , i have collected and submitted all artifacts. However the Ancient Nautilus and the Amphibian Fossil are still shown as undiscovered even though the museum clearly has it in the collection

Im trying to 100% the game, and this is the last thing i need to complete, just wondering if this error will be fixed in the next update?
 
Top